Issue #11249 has been updated by Tomoyuki Chikanaga.

Backport changed from 2.0.0: WONTFIX, 2.1: REQUIRED, 2.2: REQUIRED to 2.0.0: WONTFIX, 2.1: REQUIRED, 2.2: DONE

Backported into `ruby_2_2` branch at r51076.

----------------------------------------
Bug #11249: Fix require paths for BigDecimal and io-console
https://bugs.ruby-lang.org/issues/11249#change-53218

* Author: Vit Ondruch
* Status: Closed
* Priority: Normal
* Assignee: Hiroshi SHIBATA
* ruby -v: ruby 2.3.0dev (2015-06-10 trunk 50815) [x86_64-linux]
* Backport: 2.0.0: WONTFIX, 2.1: REQUIRED, 2.2: DONE
----------------------------------------
The .rb files under the lib directory will never get on the load path with the currently specified require paths, hence if someone installed the gem from RubyGems, only the binary extension would get loaded, but the original bundled Ruby files will be used instead of the new ones. This patches should narrow the situation.

https://github.com/ruby/ruby/pull/929



-- 
https://bugs.ruby-lang.org/