Issue #11321 has been updated by Nobuyoshi Nakada.

Status changed from Open to Third Party's Issue

Ask the authors of the gem which requires ffi.
ffi provides ability of native extensions to ruby, including segfaults.

----------------------------------------
Bug #11321: Segmentation fault
https://bugs.ruby-lang.org/issues/11321#change-53206

* Author: aisha k
* Status: Third Party's Issue
* Priority: Normal
* Assignee: 
* ruby -v: 
* Backport: 2.0.0: UNKNOWN, 2.1: UNKNOWN, 2.2: UNKNOWN
----------------------------------------
I have installed ffi gem because the rest client gem would not work without it. When I ran my code I got the following error:
lib/ffi/library.rb:263: []segmentation fault. 

After which it printed a bunch of data and terminated. Line 263 is as the following:
 invoker.attach(self, mname.to_s)

Where is the seg fault? How can I fix this?



-- 
https://bugs.ruby-lang.org/