Issue #11169 has been updated by Khoa Bui.

Assignee set to Nobuyoshi Nakada

Nobuyoshi Nakada wrote:
> Seems you are running 2.0.0 with an extension library for 2.2.
> Check your ruby's version.

My ruby version is 2.2.1
I am new to Ruby and Rails so any help would be greatly appreciated! :) 

----------------------------------------
Bug #11169: Symbol not found: _rb_str_new_static
https://bugs.ruby-lang.org/issues/11169#change-52612

* Author: Khoa Bui
* Status: Feedback
* Priority: Low
* Assignee: Nobuyoshi Nakada
* ruby -v: 2.2.1
* Backport: 2.0.0: UNKNOWN, 2.1: UNKNOWN, 2.2: UNKNOWN
----------------------------------------
when i'm running **rails server** i'm getting this message below:

~~~
Warning: You're using Rubygems 2.0.14 with Spring. Upgrade to at least Rubygems 2.1.0 and run `gem pristine --all` for better startup performance.
dyld: lazy symbol binding failed: Symbol not found: _rb_str_new_static
  Referenced from: /Users/buihdk/.rvm/gems/ruby-2.2.1/gems/json-1.8.2/lib/json/ext/parser.bundle
  Expected in: flat namespace

dyld: Symbol not found: _rb_str_new_static
  Referenced from: /Users/buihdk/.rvm/gems/ruby-2.2.1/gems/json-1.8.2/lib/json/ext/parser.bundle
  Expected in: flat namespace

Trace/BPT trap: 5
~~~

Does anyone know the solution for this issue?

Thanks!



-- 
https://bugs.ruby-lang.org/