Issue #9639 has been updated by Hiroshi SHIBATA.

Status changed from Open to Feedback

Can you try with Ruby 2.1.6?

----------------------------------------
Bug #9639: libyaml not found, rubygems not functional on freebsd with ruby 2.1.0
https://bugs.ruby-lang.org/issues/9639#change-52554

* Author: Shark Lasers
* Status: Feedback
* Priority: Normal
* Assignee: Aaron Patterson
* ruby -v: 2.1.0
* Backport: 1.9.3: UNKNOWN, 2.0.0: UNKNOWN, 2.1: UNKNOWN
----------------------------------------
Please see the full report here: https://github.com/sstephenson/ruby-build/issues/509

Note that ruby -v is not functional either per below:

~~~
stealth% ruby -v
/home/me/.rbenv/versions/2.1.0/lib/ruby/2.1.0/yaml.rb:4:in `<top (required)>':
It seems your ruby installation is missing psych (for YAML output).
To eliminate this warning, please install libyaml and reinstall your ruby.
/home/me/.rbenv/versions/2.1.0/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require': Shared object "libyaml-0.so.2" not found, required by "psych.so" - /home/me/.rbenv/versions/2.1.0/lib/ruby/2.1.0/x86_64-freebsd9.1/psych.so (LoadError)
	from /home/me/.rbenv/versions/2.1.0/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
	from /home/me/.rbenv/versions/2.1.0/lib/ruby/2.1.0/psych.rb:1:in `<top (required)>'
	from /home/me/.rbenv/versions/2.1.0/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
	from /home/me/.rbenv/versions/2.1.0/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
	from /home/me/.rbenv/versions/2.1.0/lib/ruby/2.1.0/yaml.rb:5:in `<top (required)>'
	from /home/me/.rbenv/versions/2.1.0/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
	from /home/me/.rbenv/versions/2.1.0/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
	from /home/me/.rbenv/versions/2.1.0/lib/ruby/2.1.0/rubygems.rb:616:in `load_yaml'
	from /home/me/.rbenv/versions/2.1.0/lib/ruby/2.1.0/rubygems/config_file.rb:327:in `load_file'
	from /home/me/.rbenv/versions/2.1.0/lib/ruby/2.1.0/rubygems/config_file.rb:196:in `initialize'
	from /home/me/.rbenv/versions/2.1.0/lib/ruby/2.1.0/rubygems/gem_runner.rb:74:in `new'
	from /home/me/.rbenv/versions/2.1.0/lib/ruby/2.1.0/rubygems/gem_runner.rb:74:in `do_configuration'
	from /home/me/.rbenv/versions/2.1.0/lib/ruby/2.1.0/rubygems/gem_runner.rb:39:in `run'
	from /home/me/.rbenv/versions/2.1.0/bin/gem:21:in `<main>'
~~~



-- 
https://bugs.ruby-lang.org/