Issue #10952 has been updated by Usaku NAKAMURA.

Backport changed from 2.0.0: WONTFIX, 2.1: REQUIRED, 2.2: REQUIRED to 2.0.0: WONTFIX, 2.1: DONE, 2.2: REQUIRED

ruby_2_1 r50574 merged revision(s) 50185.

----------------------------------------
Bug #10952: Clarify BigDecimal license
https://bugs.ruby-lang.org/issues/10952#change-52534

* Author: Vit Ondruch
* Status: Closed
* Priority: Normal
* Assignee: Kenta Murata
* ruby -v: trunk
* Backport: 2.0.0: WONTFIX, 2.1: DONE, 2.2: REQUIRED
----------------------------------------
The README [1] says:

~~~
You can redistribute it and/or modify it under either the terms of the GPL
(see COPYING file), or the conditions below:
~~~

So it is GPL or Ruby license. Nevertheless, the file headers [2, 3] says something different while referring back to the README.:

~~~
* You may distribute under the terms of either the GNU General Public
* License or the Artistic License, as specified in the README file
* of this BigDecimal distribution.
~~~

Could you please clarify the licenses?



[1] https://github.com/ruby/ruby/blob/trunk/ext/bigdecimal/README#L5
[2] https://github.com/ruby/ruby/blob/trunk/ext/bigdecimal/bigdecimal.c#L7
[3] https://github.com/ruby/ruby/blob/trunk/ext/bigdecimal/bigdecimal.h#L7



-- 
https://bugs.ruby-lang.org/