Issue #10925 has been updated by Tomoyuki Chikanaga.

Backport changed from 2.0.0: DONTNEED, 2.1: DONTNEED, 2.2: REQUIRED to 2.0.0: DONTNEED, 2.1: DONTNEED, 2.2: DONE

r49693 was already backported into `ruby_2_2` branch at r49719 for #10887.

----------------------------------------
Bug #10925: Backport r49693
https://bugs.ruby-lang.org/issues/10925#change-52491

* Author: Hiroshi SHIBATA
* Status: Closed
* Priority: Normal
* Assignee: 
* ruby -v: 2.2.0
* Backport: 2.0.0: DONTNEED, 2.1: DONTNEED, 2.2: DONE
----------------------------------------
Please backport r49693, this commit fixed failing spec on rubyspec.

https://github.com/ruby/ruby/commit/9759173cfc954f89a24dd96a42067161a34bd243



-- 
https://bugs.ruby-lang.org/