Issue #11159 has been updated by Tomoyuki Chikanaga.

Backport changed from 2.0.0: REQUIRED, 2.1: REQUIRED, 2.2: REQUIRED to 2.0.0: REQUIRED, 2.1: REQUIRED, 2.2: DONE

Backported into `ruby_2_2` branch at r50543.

----------------------------------------
Bug #11159: RubyVM::InstructionSequence.compile(nil) #=> segfault
https://bugs.ruby-lang.org/issues/11159#change-52489

* Author: Kyrylo Silin
* Status: Closed
* Priority: Normal
* Assignee: 
* ruby -v: ruby 2.2.2p95 (2015-04-13 revision 50295) [x86_64-linux]
* Backport: 2.0.0: REQUIRED, 2.1: REQUIRED, 2.2: DONE
----------------------------------------
The following code causes a segfault both for Ruby 2.2.2 and Ruby 2.2.0 (I haven't tested other versions).

The trace is attached.

~~~ruby
RubyVM::InstructionSequence.compile(nil)
~~~

---Files--------------------------------
ruby_vm_compile_segfault.txt (9.54 KB)


-- 
https://bugs.ruby-lang.org/