Issue #8000 has been updated by Vit Ondruch.

Backport changed from 2.0.0: REQUIRED, 2.1: REQUIRED to 2.0.0: REQUIRED, 2.1: DONE

----------------------------------------
Bug #8000: "require 'tk'" segfaults on 64-bit linux with Tk 8.6
https://bugs.ruby-lang.org/issues/8000#change-52434

* Author: Ed McCardell
* Status: Closed
* Priority: Normal
* Assignee: Hidetoshi Nagai
* ruby -v: ruby 1.9.3p392 (2013-02-22 revision 39386) [x86_64-linux]
* Backport: 2.0.0: REQUIRED, 2.1: DONE
----------------------------------------
Using ruby 1.9.3p392 and Tk 8.6.0 on 64-bit Arch Linux, attempting to "require 'tk'" causes a segfault.

To reproduce:
    ruby -e "require 'tk'"

The crash log is in the attached file.

Notes:
- I've heard from a Gentoo user who is having the same problem.
- On 32-bit Arch Linux, there is no problem.

---Files--------------------------------
crash.log (16.2 KB)
bt.txt (1.82 KB)
bt-debug.txt (4.47 KB)
crash-2.txt (4.49 KB)
0001-Fix-tk-crash-with-Tk-8.6.1-on-Ubuntu.patch (2.36 KB)
tk-diff-ruby-1.9.3-p547 (17.8 KB)
tk-diff-ruby-2.0.0-p576 (17.6 KB)
tk-diff-ruby-2.1.3-p242 (17.2 KB)


-- 
https://bugs.ruby-lang.org/