Issue #11111 has been updated by Tomoyuki Chikanaga.

Backport changed from 2.0.0: REQUIRED, 2.1: DONE, 2.2: REQUIRED to 2.0.0: REQUIRED, 2.1: DONE, 2.2: DONE

r50410, r50412, r50413, r50414, r50415 and r50416 were backported into `ruby_2_2` at r50486.

----------------------------------------
Bug #11111: Backport incompatible libruby check
https://bugs.ruby-lang.org/issues/11111#change-52426

* Author: Nobuyoshi Nakada
* Status: Closed
* Priority: Normal
* Assignee: 
* ruby -v: r50413
* Backport: 2.0.0: REQUIRED, 2.1: DONE, 2.2: DONE
----------------------------------------
Please backport r50410, r50412, and r50413, to get rid of frequently reported stale bugs.
These changes raise an exception when an extension library linked to an incompatible ruby is loaded.



-- 
https://bugs.ruby-lang.org/