Issue #11070 has been updated by Chris Rollins.


Nobuyoshi Nakada wrote:
> > ~~~
> > 2   libruby.2.2.0.dylib                 0x000000010057f2a3 sigsegv + 83
> > 3   libsystem_platform.dylib            0x00007fff8f6daf1a _sigtramp + 26
> > 4   libruby.2.1.0.dylib                 0x00000001023e7781 ruby_xmalloc + 17
> 
> An extension library for 2.1.0.

Sorry, I'm a newbie to Ruby. What is the issue here? I uninstalled/reinstalled ruby and I'm getting the same issue. Looks like a lib is from 2.1 and not compatible with 2.2? How do I resolve?

----------------------------------------
Bug #11070: Can't launch rails after upgrading to v.2.2.0
https://bugs.ruby-lang.org/issues/11070#change-52171

* Author: Chris Rollins
* Status: Rejected
* Priority: Normal
* Assignee: 
* ruby -v: ruby 2.2.0p0 (2014-12-25 revision 49005) [x86_64-darwin14]
* Backport: 2.0.0: UNKNOWN, 2.1: UNKNOWN, 2.2: UNKNOWN
----------------------------------------
After upgrading ruby to v 2.2.0, rails server no longer will launch. I've created other rails application with the same error. I also run rake commands and get the same error.

---Files--------------------------------
stack_trace.txt (108 KB)


-- 
https://bugs.ruby-lang.org/