Issue #11030 has been reported by Vadim A. Misbakh-Soloviov.

----------------------------------------
Bug #11030:  Ruby 2.2.1 fails to compile with hardened GCC
https://bugs.ruby-lang.org/issues/11030

* Author: Vadim A. Misbakh-Soloviov
* Status: Open
* Priority: Normal
* Assignee: 
* ruby -v: 2.2.1
* Backport: 2.0.0: UNKNOWN, 2.1: UNKNOWN, 2.2: UNKNOWN
----------------------------------------
Hi there!
I've discovered, that Ruby 2.2.1 can't be built using Hardened GCC (4.8 and 4.9).
Probably, that was introduced in that commit: http://svn.ruby-lang.org/cgi-bin/viewvc.cgi/tags/v2_2_1/thread_pthread.c?r1=48992&r2=49578&diff_format=h

Additional info and build logs can be found on downstream bug tracker: https://bugs.gentoo.org/show_bug.cgi?id=542610
(unfortunately, ruby maintainers in downstream are slackers, so I going to report that to upstream myself).



-- 
https://bugs.ruby-lang.org/