Issue #10986 has been updated by Friedrich Heinrichmeyer.

File irb-bat.png added

fancy_irb-0.8.1(Ruby 2.0.0p481 (2014-05-08) [x64-mingw32])
I can”Ēt not the old input line error free edited. See screen photo (attachment).

fancy_irb-0.7.3(IRB: You are using ruby 1.9.3p374 (2013-01-15)) was error free.

Mit freundlichen Gren, Fritz Heinrichmeyer


----------------------------------------
Bug #10986: fancy_irb broken
https://bugs.ruby-lang.org/issues/10986#change-51917

* Author: Friedrich Heinrichmeyer
* Status: Closed
* Priority: Normal
* Assignee: Nobuyoshi Nakada
* ruby -v: ruby 2.0.0p481 (2014-05-08) [i386-mingw32]
* Backport: 2.0.0: UNKNOWN, 2.1: UNKNOWN, 2.2: UNKNOWN
----------------------------------------
~~~
 ruby -v
ruby 2.0.0p481 (2014-05-08) [i386-mingw32]
c:\Ruby200-x64\bin>irb
DL is deprecated, please use Fiddle
c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/fancy_irb-0.8.0/lib/fancy_irb/terminal_i
nfo.rb:10:in `winsize': Bad file descriptor (Errno::EBADF)
        from c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/fancy_irb-0.8.0/lib/fancy_i
rb/terminal_info.rb:10:in `cols'
        from c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/fancy_irb-0.8.0/lib/fancy_i
rb/implementation.rb:84:in `track_height'
        from c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/fancy_irb-0.8.0/lib/fancy_i
rb/implementation.rb:148:in `block in patch_stream'
        from c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/fancy_irb-0.8.0/lib/fancy_i
rb/clean_up.rb:1:in `print'
        from c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/fancy_irb-0.8.0/lib/fancy_i
rb/clean_up.rb:1:in `block in <top (required)>'
c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/fancy_irb-0.8.0/lib/fancy_irb/terminal_i
nfo.rb:10:in `winsize': Bad file descriptor (Errno::EBADF)
        from c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/fancy_irb-0.8.0/lib/fancy_i
rb/terminal_info.rb:10:in `cols'
        from c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/fancy_irb-0.8.0/lib/fancy_i
rb/implementation.rb:84:in `track_height'
        from c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/fancy_irb-0.8.0/lib/fancy_i
rb/implementation.rb:148:in `block in patch_stream'
        from c:/Ruby200-x64/lib/ruby/2.0.0/irb/init.rb:239:in `print'
        from c:/Ruby200-x64/lib/ruby/2.0.0/irb/init.rb:239:in `rescue in run_con
fig'
        from c:/Ruby200-x64/lib/ruby/2.0.0/irb/init.rb:235:in `run_config'
        from c:/Ruby200-x64/lib/ruby/2.0.0/irb/init.rb:19:in `setup'
        from c:/Ruby200-x64/lib/ruby/2.0.0/irb.rb:380:in `start'
        from irb:12:in `<main>'
gem list io-console

*** LOCAL GEMS ***

io-console (0.4.2)

C:\Users\Fritz Heinrichmeyer>ruby -r io/console -e 'p STDIN.winsize'
-e:1:in `winsize': Bad file descriptor (Errno::EBADF)
        from -e:1:in `<main>'

irb(main):001:0> require 'io/console/size'
=> true
irb(main):002:0> [ENV["LINES"], ENV["COLUMNS"]]
=> ["300", "80"]
irb(main):003:0> IO.console_size
=> [25, 80]

irb(main):007:0> [`tput lines`, `tput cols`]
Errno::ENOENT: No such file or directory - tput lines
        from (irb):7:in ``'
        from (irb):7
        from irb:12:in `<main>'
irb(main):008:0> require "English"
=> true
irb(main):009:0> $LOAD_PATH
=> ["c:/Ruby200-x64/lib/ruby/site_ruby/2.0.0", "c:/Ruby200-x64/lib/ruby/site_rub
y/2.0.0/x64-msvcrt", "c:/Ruby200-x64/lib/ruby/site_ruby", "c:/Ruby200-x64/lib/ru
by/vendor_ruby/2.0.0", "c:/Ruby200-x64/lib/ruby/vendor_ruby/2.0.0/x64-msvcrt", "
c:/Ruby200-x64/lib/ruby/vendor_ruby", "c:/Ruby200-x64/lib/ruby/2.0.0", "c:/Ruby2
00-x64/lib/ruby/2.0.0/x64-mingw32"]
irb(main):010:0> $DEFAULT_OUTPUT
=> #<IO:<STDOUT>>
~~~

Mit freundlichen Gren, Fritz Heinrichmeyer 



---Files--------------------------------
irb-bat.png (19.3 KB)


-- 
https://bugs.ruby-lang.org/