Issue #10898 has been reported by Patrick Hogan.

----------------------------------------
Bug #10898: Cannot compile Ruby 2.2.0 with configure error: something wrong with LDFLAGS=""
https://bugs.ruby-lang.org/issues/10898

* Author: Patrick Hogan
* Status: Open
* Priority: Normal
* Assignee: 
* ruby -v: ruby 2.2.0p0 (2014-12-25 revision 49005) [x86_64-darwin14]
* Backport: 2.0.0: UNKNOWN, 2.1: UNKNOWN, 2.2: UNKNOWN
----------------------------------------
To replicate, download and unzip Ruby-2.2.0
In terminal:
export LIBRARY_PATH=/foo/bar:$LIBRARY_PATH
./configure

Configure will fail with the following error:
configure: error: something wrong with LDFLAGS=""

It appears to be unimportant what LIBRARY_PATH is set to. As long as it is not empty, the error occurs.

If setting the LIBRARY_PATH environment variable is truly a problem, configure should at least give a more meaningful error instead of this unhelpful message that takes forever to track the cause of. :)

Platform: OSX 10.10.2
I know for a fact this happened with previous versions of OS X and previous versions of Ruby.

Thanks!




-- 
https://bugs.ruby-lang.org/