Issue #10834 has been updated by Nobuyoshi Nakada.

File bug-10834.log added
Description updated
Status changed from Open to Third Party's Issue
Backport changed from 2.0.0: UNKNOWN, 2.1: UNKNOWN, 2.2: UNKNOWN to 2.0.0: DONTNEED, 2.1: DONTNEED, 2.2: DONTNEED

----------------------------------------
Bug #10834: Segmentation fault when I try to do rails server in Windows 7 home edition 64bits
https://bugs.ruby-lang.org/issues/10834#change-51443

* Author: Max Max
* Status: Third Party's Issue
* Priority: Normal
* Assignee: 
* ruby -v: ruby 2.1.5p273 (2014-11-13 revision 48405) [x64-mingw32]
* Backport: 2.0.0: DONTNEED, 2.1: DONTNEED, 2.2: DONTNEED
----------------------------------------
I've had installed Ruby Installer 2.1 then DevKit, after that rubyGem last version, then rails 4.0.0, after that MySQL Community Server 5.6.23 for windows,
 then I download `mysql-connector-c-6.1.5-winx64` and extract in `C:\mysql-connector` I've copied `C:\mysql-connector\lib\libmysql.dll` to my Ruby 
 folder `C:\Ruby21-x64\bin` and I execute in cmd.exe this command gem install mysql2 `--platform=ruby -- '--with-mysql-dir="C:\mysql-connector"'` and everything was right.

Then I create a project: 

~~~
C:\Sites\>rails new example -d mysql
C:\Sites\>bundle install
~~~

I edit database.yml like this:

~~~yaml
development:
  adapter: mysql2
  encoding: utf8
  database: ruby_example
  pool: 5
  username: root
  password:	test
  host: localhost
~~~

When I run

~~~
C:\Sites\>rails server
~~~

this is the output:

~~~
C:/Ruby21-x64/lib/ruby/gems/2.1.0/extensions/x64-mingw32/2.1.0/mysql2-0.3.17/mysql2/mysql2.so: [BUG] Segmentation fault
ruby 2.1.5p273 (2014-11-13 revision 48405) [x64-mingw32]
(snip)
~~~


---Files--------------------------------
bug-10834.log (54.2 KB)


-- 
https://bugs.ruby-lang.org/