Issue #10742 has been updated by Nobuyoshi Nakada.

Status changed from Feedback to Third Party's Issue

Using dl and ffi is outside ruby.
Ask those gems' authors.


----------------------------------------
Misc #10742: segmentation fault error while running ruby project
https://bugs.ruby-lang.org/issues/10742#change-51357

* Author: Geetanjali Kasar
* Status: Third Party's Issue
* Priority: Low
* Assignee: 
----------------------------------------
Hi,
I tried Ruby1.9.3,Ruby 2.0.0,Ruby 2.1.5 64 bit and 32 bit versions along with watir 4.0.0,cucumber 2.0.1. But everytime I am getting segmentation fault error while reading step definition file. I have windows7 system and running project from commnad promt and using netbeans.

I read all blogs but could not solve it. I searched for rubydebuuger gem, but it was not installed while running bundle install.
My Gemfile-

~~~ruby
gem "watir", "~>4.0"
gem 'cucumber', '1.0.2'
#gem "bundler", "1.2.3"
gem 'require_all', '1.2.1'
~~~



-- 
https://bugs.ruby-lang.org/