Issue #10736 has been reported by Eike Dierks.

----------------------------------------
Bug #10736: configure does not check for missing ruby
https://bugs.ruby-lang.org/issues/10736

* Author: Eike Dierks
* Status: Open
* Priority: Normal
* Assignee: 
* ruby -v: ruby 2.2.0p0 (2014-12-25 revision 49005)
* Backport: 2.0.0: UNKNOWN, 2.1: UNKNOWN, 2.2: UNKNOWN
----------------------------------------
The ./configure script should check if a version of ruby is installed.

Currently not such check is performed.

Current behaviour:
configure succeeds even if the is no version of ruby available.
make fails with: "executable host ruby is required. use --with-baseruby option."

Suggested behaviour:
configure should check for a usable ruby
This check should be performed early in ./configure
as any further attempt to build will fail if no ruby is available







-- 
https://bugs.ruby-lang.org/