Issue #10716 has been updated by Vit Ondruch.


Nobuyoshi Nakada wrote:
> Vit Ondruch wrote:
> > BTW I am wondering why Ruby actually enforces autoconf 2.67 and makes plenty of RHEL 6/CentOS 6 users [1] unnecessary issues, when it builds with 2.63 just fine. If there was some justification at least [2].
> 
> Because we wanted to skip autoconf 2.64 and 2.66 but `AC_PREREQ()` can't skip them but allow 2.63.

Ok, that makes sense. So I'll happily change the AC_PREREQ back to 2.63 for RHEL 6/CentOS 6 packages. Thanks for applying the patch.

----------------------------------------
Bug #10716: Erroneous semicolon after AC_CASE
https://bugs.ruby-lang.org/issues/10716#change-50878

* Author: Vit Ondruch
* Status: Closed
* Priority: Normal
* Assignee: 
* Category: 
* Target version: 
* ruby -v: ruby 2.2.0p0 (2014-12-25 revision 49005) [x86_64-linux-gnu]
* Backport: 2.0.0: UNKNOWN, 2.1: REQUIRED, 2.2: REQUIRED
----------------------------------------
This is issue when building with autoconf 2.63 available in RHEL6/CentOS6

BTW I am wondering why Ruby actually enforces autoconf 2.67 and makes plenty of RHEL 6/CentOS 6 users [1] unnecessary issues, when it builds with 2.63 just fine. If there was some justification at least [2].



[1] https://www.google.cz/search?q=ruby+Autoconf+version+2.67+or+higher+is+required
[2] https://github.com/ruby/ruby/commit/ecb9b98774b01b2eff22fe4a9832ce469f3552e8

---Files--------------------------------
0001-Remove-superfluous-semicolon.patch (949 Bytes)


-- 
https://bugs.ruby-lang.org/