Issue #10610 has been updated by Vit Ondruch.

Related to Feature #9852: How to bundle test-unit2 and minitest5 added

----------------------------------------
Bug #10610: "make install" fails without zbli
https://bugs.ruby-lang.org/issues/10610#change-50454

* Author: Vit Ondruch
* Status: Open
* Priority: Normal
* Assignee: 
* Category: 
* Target version: 
* ruby -v: ruby 2.2.0dev (2014-12-17 trunk 48879) [x86_64-linux]
* Backport: 2.0.0: UNKNOWN, 2.1: UNKNOWN
----------------------------------------
I just noticed, that Ruby cannot be installed in case zlib is not available on the system:

~~~
installing bundle gems:       /usr/share/ruby/gems/ (build_info, cache, doc, extensions, gems, specifications)
/builddir/build/BUILD/ruby-2.2.0-r48879/lib/rubygems/core_ext/kernel_require.rb:54:in `require': cannot load such file -- zlib (LoadError)
	from /builddir/build/BUILD/ruby-2.2.0-r48879/lib/rubygems/core_ext/kernel_require.rb:54:in `require'
	from /builddir/build/BUILD/ruby-2.2.0-r48879/lib/rubygems/package.rb:46:in `<top (required)>'
	from /builddir/build/BUILD/ruby-2.2.0-r48879/lib/rubygems/core_ext/kernel_require.rb:54:in `require'
	from /builddir/build/BUILD/ruby-2.2.0-r48879/lib/rubygems/core_ext/kernel_require.rb:54:in `require'
	from /builddir/build/BUILD/ruby-2.2.0-r48879/lib/rubygems/dependency_installer.rb:3:in `<top (required)>'
	from /builddir/build/BUILD/ruby-2.2.0-r48879/lib/rubygems/core_ext/kernel_require.rb:54:in `require'
	from /builddir/build/BUILD/ruby-2.2.0-r48879/lib/rubygems/core_ext/kernel_require.rb:54:in `require'
	from /builddir/build/BUILD/ruby-2.2.0-r48879/lib/rubygems.rb:556:in `install'
	from ./tool/rbinstall.rb:726:in `block (2 levels) in <main>'
	from ./tool/rbinstall.rb:725:in `each'
	from ./tool/rbinstall.rb:725:in `block in <main>'
	from ./tool/rbinstall.rb:758:in `call'
	from ./tool/rbinstall.rb:758:in `block in <main>'
	from ./tool/rbinstall.rb:755:in `each'
	from ./tool/rbinstall.rb:755:in `<main>'
uncommon.mk:244: recipe for target 'do-install-all' failed
make: *** [do-install-all] Error 1
~~~

This is probably the case since the minitest and test-unit gems were imported. Shouldn't in this case the build process fail earlier, during configuration presumably?

BTW I still believe that the gems should be in the repository in their source form and RubyGems should not be used directly for their installation precisely due to this kind of issues [1]. So may be **not** fixing this at all might be solution for this moment as well ;)


[1] https://bugs.ruby-lang.org/issues/9852#note-15



-- 
https://bugs.ruby-lang.org/