Issue #10566 has been updated by Marty Plummer.


Nobuyoshi Nakada wrote:
> Applied in changeset r48711.
> 
> ----------
> extmk.rb: no EXTOBJS to main if enable-shared
> 
> * ext/extmk.rb: as all extension objects including initializations
>   of ext and enc shouild be linked to libruby if enable-shared,
>   EXTOBJS should not be linked to main programs.
>   [ruby-core:66675] [Bug #10566]

Ah, many thanks! I just reran makepkg, which updates source of repo-based builds, and it worked. Was scratching my head for a second there, then I noticed your post with the fix. Huge thanks, quick resolution :)

----------------------------------------
Bug #10566: Failure to compile ruby-trunk via mingw-w64 on linux
https://bugs.ruby-lang.org/issues/10566#change-50300

* Author: Marty Plummer
* Status: Closed
* Priority: Normal
* Assignee: 
* Category: 
* Target version: 
* ruby -v: ruby 2.2.0dev (2014-12-03 trunk 48697) [x86_64-linux]
* Backport: 2.0.0: DONTNEED, 2.1: DONTNEED
----------------------------------------
=begin
Greetings;
  In my quest for optimizing my network usage (very slow connection), I've been migrating my
archlinux installation to a sort of gentoo setup, building my own packages from source repos.
In the process of that, I've written a PKGBUILD file to compile ruby, lib32-libruby, and
mingw-w64-ruby.

  While the recipe works fine against ruby 2.1.5's source code, I'm running into issues with
ruby-trunk, either from the svn repo or the git mirror. ruby and lib32-libruby both compile
fine, but the mingw-w64 build fails at attempting to link ruby.exe and rubyw.exe, citing a
number of undefined references to Init_<exts> in extinit.c, while the dll, dll.a, and static.a
files compile just fine. While I am solely building for the sake of using it as a linked in
library for embedding this is hopefully of little concern to me, however I feel it
is my duty to report the issue here.


---Files--------------------------------
make.log (5.07 KB)


-- 
https://bugs.ruby-lang.org/