Issue #10566 has been updated by Marty Plummer.


Ah, one second. Some of the redundancy is due to archlinux shipping a pair of configure wrapper scripts to make looping the build for i686 and x86_64 w64-mingw32 simpler; I was not aware that --disable-install-doc implies the others, I adopted a PKGBUILD that last worked on some 2.0.0 ruby version, and I figured if it wasn't broke, don't fix it.

Give me a bit, I'm doing real physical work at home, and I'm running the build again against the latest svn to get the exts.mk file untainted by my experimentation.

----------------------------------------
Bug #10566: Failure to compile ruby-trunk via mingw-w64 on linux
https://bugs.ruby-lang.org/issues/10566#change-50299

* Author: Marty Plummer
* Status: Closed
* Priority: Normal
* Assignee: 
* Category: 
* Target version: 
* ruby -v: ruby 2.2.0dev (2014-12-03 trunk 48697) [x86_64-linux]
* Backport: 2.0.0: DONTNEED, 2.1: DONTNEED
----------------------------------------
=begin
Greetings;
  In my quest for optimizing my network usage (very slow connection), I've been migrating my
archlinux installation to a sort of gentoo setup, building my own packages from source repos.
In the process of that, I've written a PKGBUILD file to compile ruby, lib32-libruby, and
mingw-w64-ruby.

  While the recipe works fine against ruby 2.1.5's source code, I'm running into issues with
ruby-trunk, either from the svn repo or the git mirror. ruby and lib32-libruby both compile
fine, but the mingw-w64 build fails at attempting to link ruby.exe and rubyw.exe, citing a
number of undefined references to Init_<exts> in extinit.c, while the dll, dll.a, and static.a
files compile just fine. While I am solely building for the sake of using it as a linked in
library for embedding this is hopefully of little concern to me, however I feel it
is my duty to report the issue here.


---Files--------------------------------
make.log (5.07 KB)


-- 
https://bugs.ruby-lang.org/