Issue #7793 has been updated by Andrew M.


Below is a summary of the different naming proposals so far in this thread, with links to the documentation for real-world implementations where available.

# Option 1

The original proposal, uses the term `map` to express changing the keys or values on the hash, and keeps things terse by abbreviating the terms 'key' and 'value':

* `Hash#map_k`
* `Hash#map_k!`
* `Hash#map_vs`
* `Hash#map_v!`
* `Hash#map_kv`
* `Hash#map_kv!`


# Option 2

A clearer, more verbose alternative to option 1. (Proposed by Charlie Somerville.)

* [`Hash#map_keys`](http://www.rubydoc.info/github/phluid61/hashmap-gem/master/Hash#map_keys-instance_method)
* [`Hash#map_keys!`](http://www.rubydoc.info/github/phluid61/hashmap-gem/master/Hash#map_keys%21-instance_method)
* [`Hash#map_values`](http://www.rubydoc.info/github/phluid61/hashmap-gem/master/Hash#map_values-instance_method)
* [`Hash#map_values!`](http://www.rubydoc.info/github/phluid61/hashmap-gem/master/Hash#map_pairs%21-instance_method)
* [`Hash#map_pairs`](http://www.rubydoc.info/github/phluid61/hashmap-gem/master/Hash#map_pairs-instance_method)
* [`Hash#map_pairs!`](http://www.rubydoc.info/github/phluid61/hashmap-gem/master/Hash#map_pairs%21-instance_method)


# Option 3

Given the existing methods `Hash#each_key`, `Hash#each_value`, and `Hash#each_pair`, it might be better to use a sigular alternative to option 2. (Proposed by Nobuyoshi Nakada.)

* `Hash#map_key`
* `Hash#map_key!`
* `Hash#map_value`
* `Hash#map_value!`
* `Hash#map_pair`
* `Hash#map_pair!`


# Option 4

Given the potential for the previous options to be confused with `Hash#map`, which returns an array, it might be best to use an entirely different naming convention. This one is based on [Facets](https://github.com/rubyworks/facets), a popular (485,329 downloads on Rubygems) library with the purpose of extending Ruby's core classes with useful methods. (Proposed by Thomas Sawyer.)

* [`Hash#rekey`](http://www.rubydoc.info/github/rubyworks/facets/master/Hash#rekey-instance_method)
* [`Hash#rekey!`](http://www.rubydoc.info/github/rubyworks/facets/master/Hash#rekey%21-instance_method)
* [`Hash#revalue`](http://www.rubydoc.info/github/rubyworks/facets/master/Hash#revalue-instance_method)
* [`Hash#revalue!`](http://www.rubydoc.info/github/rubyworks/facets/master/Hash#revalue%21-instance_method)
* [`Enumerable#graph`](http://www.rubydoc.info/github/rubyworks/facets/master/Enumerable#graph-instance_method) (See #6669)
  * Aliased as `Enumerable#mash`
* [`Hash#graph!`](http://www.rubydoc.info/github/rubyworks/facets/master/Hash#graph%21-instance_method)
  * Aliased as `Hash#mash!`


# Option 5

Similar to option 4, but based on the naming convention used by Ruby on Rails.

* [`Hash#transform_keys`](http://api.rubyonrails.org/classes/Hash.html#method-i-transform_keys)
* [`Hash#transform_keys!`](http://api.rubyonrails.org/classes/Hash.html#method-i-transform_keys-21)
* `Hash#transform_values`
* `Hash#transform_values!`
* `Hash#transform_pairs`
* `Hash#transform_pairs!`

----------------------------------------
Feature #7793: New methods on Hash
https://bugs.ruby-lang.org/issues/7793#change-49727

* Author: Dominic Sisneros
* Status: Assigned
* Priority: Normal
* Assignee: Yukihiro Matsumoto
* Category: core
* Target version: next minor
----------------------------------------
It would be nice to have the following methods added to hash

~~~ruby
h = { name: 'dominic', request: 'add the following methods', :why => 'convenience'}

h.map_v{|v| v.upcase}
#=> {:name=>"DOMINIC", :request=>"ADD THE FOLLOWING METHODS", :why=>"CONVENIENCE"}

h.map_k{|k| k.to_s}
#=> { "name"=> 'dominic', "request"=>"add the following methods', "why" => "convenience"}

h.map_kv{|k,v| [k.to_s, v.upcase]}
#=> { "name"=>"DOMINIC", "request"=>"ADD THE FOLLOWING METHODS", "why"=>"CONVENIENCE"}


class Hash

  def map_v
    reduce({}) do |result, array|
      k,v = array
      new_val = yield v
      result.merge( k => new_val)
    end
  end

  def map_k
    reduce({}) do |result, array|
      k,v = array
      new_k = yield k
      result.merge(new_k => v)
    end
  end

  def map_kv
    reduce({}) do |result, array|
      new_k,new_v = yield array
      result.merge(new_k => new_v)
    end
  end

end




-- 
https://bugs.ruby-lang.org/