Issue #10159 has been updated by Luis Mondesi.


Ruby 2.1.3 has the same issue. The patch is already supplied, why hasn't this been addressed?

----------------------------------------
Bug #10159: Ruby 2.x Syslog::Logger is newer than the one in Rubygems but version is the same
https://bugs.ruby-lang.org/issues/10159#change-49436

* Author: Luis Mondesi
* Status: Assigned
* Priority: Normal
* Assignee: Akinori MUSHA
* Category: ext
* Target version: 
* ruby -v: ruby 2.1.2p95 (2014-05-08 revision 45877) [x86_64-linux]
* Backport: 2.0.0: UNKNOWN, 2.1: UNKNOWN
----------------------------------------
Users of Ruby 2.x get the latest version of syslog/logger.rb as included from https://bugs.ruby-lang.org/issues/5096; however, the version of the gem is not updated to reflect that this new one has more features (for example, you can pass facility information and such).

$> pry
[1] pry(main)> require 'syslog/logger'
=> true
[2] pry(main)> Syslog::Logger::VERSION
=> "2.0"
[3] pry(main)> RUBY_VERSION
=> "2.1.2"


---Files--------------------------------
0001-bump-revision-of-Syslog-Logger.patch (689 Bytes)


-- 
https://bugs.ruby-lang.org/