When I try to src-build ruby 2.1.2, after an OK `make`, it fails @ `make install`

wget http://cache.ruby-lang.org/pub/ruby/2.1/ruby-2.1.2.tar.gz
tar zxvf ruby-2.1.2.tar.gz
cd ruby-2.1.2
./configure --prefix=/usr/local/ruby-test-build
make -j4
	...
	make[1]: Leaving directory `/usr/local/src/ruby-2.1.2'
	Generating RDoc documentation
	Parsing sources...
	100% [962/962]  vsnprintf.c                                                     

	Generating RI format into /usr/local/src/ruby-2.1.2/.ext/rdoc...

	  Files:        962

	  Classes:     1414 ( 566 undocumented)
	  Modules:      268 (  87 undocumented)
	  Constants:   2097 ( 624 undocumented)
	  Attributes:  1146 ( 272 undocumented)
	  Methods:    10649 (2226 undocumented)

	  Total:      15574 (3775 undocumented)
	   75.76% documented

	  Elapsed: 219.7s
make install
	...
	config.status: creating x86_64-linux-fake.rb
	./miniruby -I./lib -I. -I.ext/common  ./tool/runruby.rb --extout=.ext  -- --disable-gems -r./x86_64-linux-fake ./tool/rbinstall.rb --make="make" --dest-dir="" --extout=".ext" --mflags="" --make-flags="" --data-mode=0644 --prog-mode=0755 --installed-list .installed.list --mantype="doc" --install=all --rdoc-output=".ext/rdoc"
	installing binary commands:   /usr/local/ruby-test-build/bin
	/usr/local/src/ruby-2.1.2/lib/fileutils.rb:247:in `mkdir': integer 8070450537616637957 too big to convert to `int' (RangeError)
	        from /usr/local/src/ruby-2.1.2/lib/fileutils.rb:247:in `fu_mkdir'
	        from /usr/local/src/ruby-2.1.2/lib/fileutils.rb:211:in `block in mkdir_p'
	        from /usr/local/src/ruby-2.1.2/lib/fileutils.rb:208:in `each'
	        from /usr/local/src/ruby-2.1.2/lib/fileutils.rb:208:in `mkdir_p'
	        from ./tool/rbinstall.rb:193:in `makedirs'
	        from ./tool/rbinstall.rb:300:in `prepare'
	        from ./tool/rbinstall.rb:339:in `block in <main>'
	        from ./tool/rbinstall.rb:789:in `call'
	        from ./tool/rbinstall.rb:789:in `block in <main>'
	        from ./tool/rbinstall.rb:786:in `each'
	        from ./tool/rbinstall.rb:786:in `<main>'
	make: *** [do-install-all] Error 1

I first stumbled on this problem trying to install latest version of ruby with `rvm install` (https://github.com/wayneeseguin/rvm/issues/3036), but as the result above appears to show -- it's independent of rvm.

I've filed a bug here,  https://bugs.ruby-lang.org/issues/10253, under a now-incorrect title suggesting it's an rvm-related problem.

Any ideas as to what the problem here is?  Possible, of course, something's missing from my env, but, so far, I've no clues ...

Grant