Issue #8315 has been updated by Hans Mackowiak.


have somone time to fix that?
currently it still does needed to fix it by myself to get the gems working

----------------------------------------
Bug #8315: mkmf does not include include paths from pkg_config anymore
https://bugs.ruby-lang.org/issues/8315#change-48712

* Author: Hans Mackowiak
* Status: Open
* Priority: Normal
* Assignee: Nobuyoshi Nakada
* Category: ext
* Target version: 
* ruby -v: trunk
* Backport: 1.9.3: UNKNOWN, 2.0.0: UNKNOWN
----------------------------------------
=begin

((*#6504*)) does that, for cpp files $CFLAGS is not used anymore, so the problems are the include paths:

* there is no $CXXFLAGS global variable defined
* pkg_config does not add the includes paths to the correct *FLAGS


so my gems are currently broken for ruby trunk and if i fix that it may be broken for the older ruby 
=end



-- 
https://bugs.ruby-lang.org/