Issue #10169 has been updated by gogo tanaka.


@Hiroshi SHIBATA

I really appreciate you doing what I should do.

----------------------------------------
Feature #10169: It might be better to make Mathn class deprecated
https://bugs.ruby-lang.org/issues/10169#change-48505

* Author: gogo tanaka
* Status: Open
* Priority: Normal
* Assignee: 
* Category: lib
* Target version: 
----------------------------------------
#English

As I mentioned in https://bugs.ruby-lang.org/issues/10086#change-48156,

1. Now that we are able to hundle complex exponents without mathn.

2. And overriding `\` with `quo` has too much side effect. I suppose we should not implement such a thing in ruby standard library.

3. Requiring and integrating other standard libraries doesn't make sense.

This is why I think it might be better to make Mathn class deprecated and disabled in the future.

#日本語(すみませんまだ英語が拙く、意図をより正確にお伝えするため日本語も記載させて頂きます)

僕がこちらのissueで述べさせて頂いた通り、https://bugs.ruby-lang.org/issues/10086#change-48156

1. `mathn` で実装されている冪乗演算は `mathn` を用いずとも現在は実現されている事

2. `mathn` 内で行われている `\` を `quo` でオーバーライドする事は副作用が強く、またこの種のオーバーライドが必要な場面は多くなく、必要な場合でも自ら実装する事が多いと推測される事

3. 各種数学関連のモジュールをrequireする機能もあまり意味を持たない事



以上の理由より、とりわけRubyの標準ライブラリーで現在の`mathn` を提供する必要を感じません.

よって`mathn`を非推奨に、ゆくゆくは廃止してしまうのが良いと考えています.



-- 
https://bugs.ruby-lang.org/