ko1 / atdot.net wrote:
> From what size on which architecture?

x86-64

> On the code:
> 
> (1) _catch_table should be catch_table

OK, I will change it back.  I renamed it so it'd be easier for the
compiler to detect places where I need to change code.

> (2) I don't like iseq_catch_table_each() macro.
> I like to write like
> ```
>   if (iseq->_catch_table) for (i=0; i<iseq->_catch_table->size; i++) {..}
> ```

OK, I didn't want to increase line length or change indentation of
existing code.

How about using a iseq_catch_table_size macro instead:
```
#define iseq_catch_table_size(iseq) \
    (iseq->catch_table ? iseq->catch_table->size : 0)

    for (i = 0; i < iseq_catch_table_size(iseq); i++) {
	...
    }
```