Btw, you're already paying significant costs for a case-insensitive FS
(not just Ruby, but things like git, too).