On 10/14/05, TRANS <transfire / gmail.com> wrote:
> George Moschovitis tried to send me a gem to try out and it would not install.
>
> trans@ubixie:~/Desktop$ gem install glue
> Attempting local installation of 'glue'
> ERROR:  Error installing gem glue[.gem]: parse error on line 0, col
> 31: `!ruby/object:Gem::Specification '
>
> A little investigation shows that the metadata file in the gem, being
> a YAML serialization of the Gemspec, lacks the initial '---' of proper
> YAML.
>
> So that's why I'm getting this error. George used 'rake gem' to create
> the package, He's running the very latest versions of everything.
> While I am still using the previous version (1.8.2). Nonetheless '---'
> should be there. The really funny thing though is this gem and it's
> bad YAML apparently work for George.

Yes. This problem has been noted as something originating with 1.8.3
and syck. The only reason, I think, that the Gems team doesn't have
something out that could handle this and/or fix this is because most
of them are heavily involved in RubyConf preparations.

-austin
--
Austin Ziegler * halostatue / gmail.com
               * Alternate: austin / halostatue.ca