Issue #9869 has been updated by Hiroshi SHIBATA.

Status changed from Assigned to Feedback

I can't reproduced it.

```
% make test-all TESTS="test/rubygems/test_*.rb"
	CC = clang
	LD = ld
	LDSHARED = clang -dynamic -bundle
	CFLAGS = -O3 -fno-fast-math -ggdb3 -Wall -Wextra -Wno-unused-parameter -Wno-parentheses -Wno-long-long -Wno-missing-field-initializers -Wunused-variable -Werror=pointer-arith -Werror=write-strings -Werror=declaration-after-statement -Werror=shorten-64-to-32 -Werror=implicit-function-declaration -Werror=division-by-zero -Werror=deprecated-declarations -Werror=extra-tokens   -pipe
	XCFLAGS = -D_FORTIFY_SOURCE=2 -fstack-protector -fno-strict-overflow -fvisibility=hidden -DRUBY_EXPORT -fPIE
	CPPFLAGS = -D_XOPEN_SOURCE -D_DARWIN_C_SOURCE -D_DARWIN_UNLIMITED_SELECT -D_REENTRANT   -I. -I.ext/include/x86_64-darwin13 -I./include -I.
	DLDFLAGS = -Wl,-undefined,dynamic_lookup -Wl,-multiply_defined,suppress -fstack-protector -Wl,-u,_objc_msgSend -Wl,-pie -framework CoreFoundation
	SOLIBS = -lgmp
Apple LLVM version 5.1 (clang-503.0.40) (based on LLVM 3.4svn)
Target: x86_64-apple-darwin13.2.0
Thread model: posix
./miniruby -I./lib -I. -I.ext/common  ./tool/runruby.rb --extout=.ext  -- --disable-gems "./test/runner.rb" --ruby="./miniruby -I./lib -I. -I.ext/common  ./tool/runruby.rb --extout=.ext  -- --disable-gems"  test/rubygems/test_*.rb
Run options: "--ruby=./miniruby -I./lib -I. -I.ext/common  ./tool/runruby.rb --extout=.ext  -- --disable-gems"

# Running tests:

Leaked tempfile: TestGemPackageTarReaderEntry: #<TempIO:/var/folders/rk/sr8p03fj4wq3f7l30gvg0r380000gn/T/TempIO20140528-33858-m2u2ix>
(snip)

Finished tests in 32.358288s, 50.8680 tests/s, 149.6371 assertions/s.
1646 tests, 4842 assertions, 0 failures, 0 errors, 0 skips

ruby -v: ruby 2.2.0dev (2014-05-28 trunk 46010) [x86_64-darwin13]
make test-all TESTS="test/rubygems/test_*.rb"  20.00s user 8.94s system 84% cpu 34.290 total
```

and http://rubyci.org didn't have test fail. It's your environment issue probably.

----------------------------------------
Bug #9869: Rubygems tests fail in test-all
https://bugs.ruby-lang.org/issues/9869#change-46940

* Author: Zachary Scott
* Status: Feedback
* Priority: Normal
* Assignee: Hiroshi SHIBATA
* Category: lib/rubygems
* Target version: current: 2.2.0
* ruby -v: 2.2.0dev
* Backport: 2.0.0: UNKNOWN, 2.1: UNKNOWN
----------------------------------------
Since minitest was removed as a default gem the rubygems tests no longer run on trunk.

You get many errors, that I reported to rubygems[1], but its only reproducible in trunk because of minitest being removed.

There's also a build failure on travis due to the same issue[2].

1: https://github.com/rubygems/rubygems/issues/927
2: https://s3.amazonaws.com/archive.travis-ci.org/jobs/26182917/log.txt (scroll to EOF)



-- 
https://bugs.ruby-lang.org/