Issue #9711 has been updated by Shota Fukumori.


I agree that we should package testing library (at least one).

I prefer bundling test-unit2 and minitest5 gem in Ruby 2.2 --
if they have some backward compatibility or they're easy to upgrade from older versions.

I'd like to hear opinion from Kou (author of test-unit.gem) and Ryan. Thoughts?

----------------------------------------
Feature #9711: Remove test-unit and minitest from stdlib.
https://bugs.ruby-lang.org/issues/9711#change-46794

* Author: Hiroshi SHIBATA
* Status: Open
* Priority: Normal
* Assignee: Ryan Davis
* Category: 
* Target version: current: 2.2.0
----------------------------------------
ref. #9660

We are hard to maintain test-unit and minitest for standard library.
I poropose to remove to their from stdlib.

see also my patches: https://github.com/hsbt/ruby/compare/extracted-test-suite?expand=1

my solution is that test-unit and minitest move to test directory.
their are used only ruby-core tests.

If people hope to use test-unit and minitest, they can download their from rubygems.

---Files--------------------------------
copy-test-unit-minitest.patch (140 KB)


-- 
https://bugs.ruby-lang.org/