A critical regression was found after the release of 1.9.3-p545[1].

Wed like a release of p546, which includes r45485[2].

In the original announcement for p545[1], it states:

> It means that Ruby 1.9.3 goes  **never be released unless any critical regressions or security issues are found.**

Also, in ruby-core:60503[3] @unak states:

> After the last usual release, we will not fix any bugs except urgent security problems, in principle.

Patch 546 is resolves a critical issue which breaks older versions of OpenSSL, which are still supported by Heroku. This includes anyone using Ubuntu 10.04 LTS which packages this version of OpenSSL.

Please clarify that @unak is still maintainer of 1.9.3, and available to dothe release. From my understanding this requires ci to be green, but sincethis is a regression from a security fix the ci was already red to begin with.


1: https://www.ruby-lang.org/en/news/2014/02/24/ruby-1-9-3-p545-is-released/
2: https://github.com/ruby/ruby/commit/680d09b
3: http://blade.nagaokaut.ac.jp/cgi-bin/scat.rb/ruby/ruby-core/60503