Issue #9800 has been updated by Koichi Sasada.


Sorry for late response.

I can agree this proposal because current default "2" also has no evidence to use.
I think more survey are welcome to set ideal default setting. 1.7? 1.5? 1.3?

However, already 2.1.2 released?


----------------------------------------
Bug #9800: Ship 2.1.2 with GC_HEAP_OLDOBJECT_LIMIT_FACTOR of 1.3
https://bugs.ruby-lang.org/issues/9800#change-46626

* Author: Sam Saffron
* Status: Open
* Priority: Normal
* Assignee: 
* Category: 
* Target version: next minor
* ruby -v: 2.1.1
* Backport: 2.0.0: UNKNOWN, 2.1: UNKNOWN
----------------------------------------
Many users are complaining about memory bloat in 2.1 series of Ruby

As denoted in https://bugs.ruby-lang.org/issues/9607 there is an excellent plan by ko1 to address this. 

In the mean time I suggest we reduce GC_HEAP_OLDOBJECT_LIMIT_FACTOR  to 1.3 which effectively means that instead of memory doubling it only increases by 1.5x or so over 2.0 series. 

It is great we have the setting, but the reality is that most users will not want to play with this. 





-- 
https://bugs.ruby-lang.org/