alexey.muranov / gmail.com wrote:
> I would like to have `File::CREATE` as a synonym for `File::CREAT`.

At least give a reason for wanting this...

Fwiw, I am against adding more aliases/synonyms to core.
They increases human overhead to learn, and machine overhead to
store/cache.

New aliases will also confuse users on old versions who may browse
the web and find the new documentation.

On a side note, perhaps we should start adding a line like:
"This was added in Ruby X.Y.Z" in our RDoc for new features.
This is common in manpages, AFAICS.