Issue #9749 has been reported by Yusuke Endoh.

----------------------------------------
Bug #9749: r45589 introduced an incompatibility
https://bugs.ruby-lang.org/issues/9749

* Author: Yusuke Endoh
* Status: Open
* Priority: Normal
* Assignee: Nobuyoshi Nakada
* Category: 
* Target version: current: 2.2.0
* ruby -v: ruby 2.2.0dev (2014-04-16 trunk 45599) [x86_64-linux]
* Backport: 2.0.0: UNKNOWN, 2.1: UNKNOWN
----------------------------------------
    $ ruby -ve 'ary = []; (1..10).each_slice(3, &lambda {|a, *| ary << a }); p ary'
    ruby 2.1.0p0 (2013-12-25 revision 44422) [x86_64-linux]
    [[1, 2, 3], [4, 5, 6], [7, 8, 9], [10]]

    $ ./miniruby -ve 'ary = []; (1..10).each_slice(3, &lambda {|a, *| ary << a }); p ary'
    ruby 2.2.0dev (2014-04-16 trunk 45599) [x86_64-linux]
    [[10], [10], [10], [10]]

See also: https://github.com/ruby/ruby/pull/596#issuecomment-40594384

-- 
Yusuke Endoh <mame / tsg.ne.jp>



-- 
https://bugs.ruby-lang.org/