Issue #9379 has been updated by Herwin ..


I guess support for Nokogiri will be possible as well, I just needed something more efficient than REXML and libXML was the first thing I tried, and it just worked.

Regarding your second point: that really needs some restructuring of loading the backends, I think that is a little bit outside the scope of this ticket. 

----------------------------------------
Feature #9379: Support for using libxml-ruby as XML parser in xmlrpc-libs
https://bugs.ruby-lang.org/issues/9379#change-46205

* Author: Herwin .
* Status: Open
* Priority: Normal
* Assignee: 
* Category: lib
* Target version: 
----------------------------------------
The default backend in the XMLRPC parser is REXML. This should work at most occasions, but it definitely isn't the fastest implementation. The attached patch allows a backend using libxml-ruby <http://xml4r.github.io/libxml-ruby/> which should be more efficient. It successfully passes the unit tests available in the file test/xmlrpc/test_parser.rb

The default isn't changed in this patch, so when libxml-ruby isn't available nothing is changed. Even if it's available, you still have to change the parsing backend before it is used. 

---Files--------------------------------
libxml-as-xmlrpc-parser.diff (1.79 KB)


-- 
https://bugs.ruby-lang.org/