hongbin034 / gmail.com wrote:
> File log-545.txt added
> 
> Got a slightly different error after upgraded to ruby 1.9.3p545:
> /usr/local/lib/ruby/1.9.1/net/protocol.rb:160: [BUG] rb_gc_mark(): unknown data type 0x0(0x6333370) corrupted object
> ruby 1.9.3p545 (2014-02-24 revision 45159) [x86_64-linux]

Hm...  Can you also try updating various C extension gems?
passenger 3.x seems old
You may also try unicorn instead (disclaimer: I maintain unicorn,
I also help out with mysql2 occasionally)