Issue #9525 has been updated by Naotoshi Seo.


Akira Tanaka wrote:
> Would anyone test the problem at latest trunk?

I had never ran fluentd with ruby 2.1.1, but now I am trying it. 
If it works well, I will try ruby-trunk next. 


----------------------------------------
Bug #9525: Stuck with Socket.pack_sockaddr_in
https://bugs.ruby-lang.org/issues/9525#change-45611

* Author: Naotoshi Seo
* Status: Closed
* Priority: Normal
* Assignee: 
* Category: 
* Target version: 
* ruby -v: 1.9.3p194
* Backport: 1.9.3: REQUIRED, 2.0.0: REQUIRED, 2.1: REQUIRED
----------------------------------------
We met this trouble with Fluentd https://github.com/fluent/fluentd. 

Fluentd is sometimes stuck at `Socket.pack_sockaddr_in` line on shutdown. 
Here is the gist https://gist.github.com/sonots/9047653 to explain details. 





-- 
http://bugs.ruby-lang.org/