Issue #9570 has been updated by Tomoyuki Chikanaga.

Backport changed from 1.9.3: DONTNEED, 2.0.0: REQUIRED, 2.1: REQUIRED to 1.9.3: DONTNEED, 2.0.0: DONE, 2.1: REQUIRED

r45187, r45205, r45212 and r45213 were backported to ruby_2_0_0 at r45250.

----------------------------------------
Bug #9570: Something wrong with Enumerator#size ?
https://bugs.ruby-lang.org/issues/9570#change-45575

* Author:  
* Status: Closed
* Priority: Normal
* Assignee: Marc-Andre Lafortune
* Category: core
* Target version: current: 2.2.0
* ruby -v: Ruby 2.0.0-p451
* Backport: 1.9.3: DONTNEED, 2.0.0: DONE, 2.1: REQUIRED
----------------------------------------
enum = 2.step(1, 3)
enum.size  #=> 1

It should be 0, shouldn't it? ( Windows )



-- 
http://bugs.ruby-lang.org/