Issue #9566 has been updated by David Bahar.


I also get segfault, both with osx 10.9.1 and 10.9.2. upgrading from ruby 2.1.0 to 2.1.1 will not work because of this. here is my console output showing the segfault:
https://gist.github.com/wasafiri/8c122abc88336a3279bc

and the osx crash log:
https://gist.github.com/wasafiri/9dcb8d4cbc9e86562f5d



----------------------------------------
Bug #9566: Psych 2.0.4 segfaults Ruby 2.1.1 on OS X 10.9.1
https://bugs.ruby-lang.org/issues/9566#change-45540

* Author: Mark Seymour
* Status: Feedback
* Priority: Normal
* Assignee: cruby-mac
* Category: platform/darwin
* Target version: 
* ruby -v:  ruby 2.1.1p76 (2014-02-24 revision 45161) [x86_64-darwin13.0]
* Backport: 1.9.3: UNKNOWN, 2.0.0: UNKNOWN, 2.1: UNKNOWN
----------------------------------------
Logs attached.

---Files--------------------------------
ruby_2014-02-25-133329_Rakka.crash (14.2 KB)
yaml_parse.log (4.89 KB)


-- 
http://bugs.ruby-lang.org/