Issue #9299 has been updated by Yukihiro Matsumoto.


I consider this as a bug.  So it should be back-ported to 2.1, I think.

Matz.


----------------------------------------
Backport #9299: Required keyowrd arguments and arity
https://bugs.ruby-lang.org/issues/9299#change-45514

* Author: Marc-Andre Lafortune
* Status: Feedback
* Priority: Normal
* Assignee: Yukihiro Matsumoto
----------------------------------------
While fixing #8072, I noticed another bug: a required keyword argument should add 1 to the arity:

    proc{|required:|}.arity # => 0, should be 1



-- 
http://bugs.ruby-lang.org/