Issue #9561 has been updated by fabio pasini.


I've tried again from home, and I was able to download successfully the file "ruby-2.1.1.zip" from both http://ftp.ruby-lang.org/pub/ruby/2.1/ and http://cache.ruby-lang.org/pub/ruby/2.1/
I also dowloaded ruby-2.0 without any problems, and all source files downloaded compiled ok here.   
Please, feel free to set this issue as invalid.
Hiroshi, Eric, thanks a lot for checking this issue.

----------------------------------------
Bug #9561: Error downloading files from repository (.zip, .tar.gz, .tar.bz2, etc)
https://bugs.ruby-lang.org/issues/9561#change-45510

* Author: fabio pasini
* Status: Feedback
* Priority: Normal
* Assignee: Hiroshi SHIBATA
* Category: misc
* Target version: 
* ruby -v: 2.1
* Backport: 1.9.3: UNKNOWN, 2.0.0: UNKNOWN, 2.1: UNKNOWN
----------------------------------------
There are errors while downloading files from both  "ftp" and "cache" repositories 
(http://ftp.ruby-lang.org/pub/ruby/2.1/ and http://cache.ruby-lang.org/pub/ruby/2.1/),
the connection is closed from server side when there are few kB to complete download.

I got this error using different download tools (wget, curl, Firefox "Download" feature, and Firefox "DownThemAll" plugin).
That is happening for different files  (.zip, .tar.gz, .tar.bz2, etc) from repositories above.






-- 
http://bugs.ruby-lang.org/