Issue #9361 has been updated by Yui NARUSE.

Backport changed from 1.9.3: DONTNEED, 2.0.0: DONTNEED, 2.1: REQUIRED to 1.9.3: DONTNEED, 2.0.0: DONTNEED, 2.1: DONE

r44858.

----------------------------------------
Bug #9361: gem install --ignore-dependencies fails to install local gems
https://bugs.ruby-lang.org/issues/9361#change-45368

* Author: Charles Nutter
* Status: Closed
* Priority: Normal
* Assignee: Eric Hodel
* Category: lib/rubygems
* Target version: next minor
* ruby -v: ruby 2.1.0p0 (2013-12-25 revision 44422) [x86_64-darwin13.0]
* Backport: 1.9.3: DONTNEED, 2.0.0: DONTNEED, 2.1: DONE
----------------------------------------
$ rvm ruby-2.1 do gem install --ignore-dependencies /Users/headius/projects/jruby/lib/ruby/gems/shared/cache/dicks-0.03.gem 
ERROR:  While executing gem ... (NoMethodError)
    undefined method `full_name' for nil:NilClass

This is also impacting JRuby master.

Also filed against RubyGems: https://github.com/rubygems/rubygems/issues/771



-- 
http://bugs.ruby-lang.org/