Issue #9224 has been updated by Tomoyuki Chikanaga.

Status changed from Assigned to Closed
% Done changed from 0 to 100

Applied in changeset r45100.

----------
(merged partially from r42927)

* lib/rubygems/core_ext/kernel_require.rb: Backport a fix for concurrent
  requires. [ruby-core:58918] [Backport #9224]
  see also https://github.com/rubygems/rubygems/pull/833

----------------------------------------
Backport #9224: rubygems's require is blocked in another thread.
https://bugs.ruby-lang.org/issues/9224#change-45366

* Author: Masahiro Nakagawa
* Status: Closed
* Priority: Normal
* Assignee: Tomoyuki Chikanaga
----------------------------------------
I tried Fluentd with ruby 2.0.0-p353, but one plugin is always blocked.
I investigated the problem and found this issue.

https://github.com/rubygems/rubygems/issues/640

Applying same changes to 2.0.0-p353 resolved blocking problem.

This bug is a critical for Fluentd like pluggable software.
Please backport this change into ruby 2.0.0 and release new version.



-- 
http://bugs.ruby-lang.org/