Issue #9492 has been updated by Yui NARUSE.

Backport changed from 1.9.3: DONTNEED, 2.0.0: DONTNEED, 2.1: REQUIRED to 1.9.3: DONTNEED, 2.0.0: DONTNEED, 2.1: DONE

r45090.

----------------------------------------
Bug #9492: ruby won't build on Mac OS X versions before 10.6 - pthread_setname_np() not available
https://bugs.ruby-lang.org/issues/9492#change-45354

* Author: Misty De Meo
* Status: Closed
* Priority: Normal
* Assignee: 
* Category: core
* Target version: 
* ruby -v: 2.1.0
* Backport: 1.9.3: DONTNEED, 2.0.0: DONTNEED, 2.1: DONE
----------------------------------------
The following commit added a usage of the pthread_setname_np() function on Darwin to set the timer thread name: https://github.com/ruby/ruby/commit/09c96a7858955f2b94238bd4bf38729f0d650f22

This function isn't available in all OS X versions; it was first added in 10.6. As a result, ruby will fail to compile on older OS X releases.



-- 
http://bugs.ruby-lang.org/