Issue #9300 has been updated by Yui NARUSE.

Backport changed from 1.9.3: DONTNEED, 2.0.0: DONTNEED, 2.1: REQUIRED to 1.9.3: DONTNEED, 2.0.0: DONTNEED, 2.1: DONE

r45079.

----------------------------------------
Bug #9300: YAML Regression Concerning Escaping of Strings
https://bugs.ruby-lang.org/issues/9300#change-45341

* Author: Richard Schneeman
* Status: Closed
* Priority: Normal
* Assignee: Aaron Patterson
* Category: 
* Target version: current: 2.2.0
* ruby -v: 2.1.0
* Backport: 1.9.3: DONTNEED, 2.0.0: DONTNEED, 2.1: DONE
----------------------------------------
=begin
When you run this code against Ruby 2.1.0 and previous versions you get different results:


 require 'YAML'
 yaml1 = {"key" => %Q{<%= ENV["PATH"] %>} }.to_yaml
 puts yaml1

Ruby 2.1.0 incorrectly escapes the quote


 ---
 key: "<%= ENV[\"PATH\"] %>"
  
While previous versions do not. Here is my original document for debugging this issue:

https://gist.github.com/schneems/8127922

=end




-- 
http://bugs.ruby-lang.org/