Issue #9472 has been updated by Yui NARUSE.

Backport changed from 1.9.3: DONE, 2.0.0: DONE, 2.1: REQUIRED to 1.9.3: DONE, 2.0.0: DONE, 2.1: DONE

r45078.

----------------------------------------
Bug #9472: rb_io_syswrite needs RB_GC_GUARD
https://bugs.ruby-lang.org/issues/9472#change-45337

* Author: Eric Wong
* Status: Closed
* Priority: Normal
* Assignee: 
* Category: 
* Target version: next minor
* ruby -v: ruby 2.2.0dev (2014-02-01 trunk 44785) [x86_64-linux]
* Backport: 1.9.3: DONE, 2.0.0: DONE, 2.1: DONE
----------------------------------------
[ruby-core:60407]
Will commit to trunk.
This needs to be backported to 2.0 and 2.1, too.



-- 
http://bugs.ruby-lang.org/