Issue #9312 has been updated by Hal Brodigan.


After updated again, I see that `make runnable` created a bin/ruby symlink. However, --enable-shared requires that LD_LIBRARY_PATH=./lib/ is set. Also, bin/ruby cannot find core libraries such as 'thread'.

----------------------------------------
Bug #9312: Build the ruby executable in bin/
https://bugs.ruby-lang.org/issues/9312#change-44528

* Author: Hal Brodigan
* Status: Feedback
* Priority: Low
* Assignee: Nobuyoshi Nakada
* Category: build
* Target version: 
* ruby -v: trunk
* Backport: 1.9.3: UNKNOWN, 2.0.0: UNKNOWN, 2.1: UNKNOWN
----------------------------------------
In order to allow Ruby Switchers to directly use a Ruby that is built but not installed (such as trunk or a branch), the ruby executable should be placed in the bin/ directory.



-- 
http://bugs.ruby-lang.org/