Issue #9348 has been reported by jeremyevans0 (Jeremy Evans).

----------------------------------------
Bug #9348:  --with-tcllib and --with-tklib configure options not working correctly
https://bugs.ruby-lang.org/issues/9348

Author: jeremyevans0 (Jeremy Evans)
Status: Open
Priority: Normal
Assignee: 
Category: 
Target version: 
ruby -v: ruby 2.1.0p0 (2013-12-25 revision 44422) [x86_64-openbsd]
Backport: 1.9.3: UNKNOWN, 2.0.0: UNKNOWN, 2.1: UNKNOWN


When using the --with-tcllib=tcl85 -with-tklib=tk85 configure options, ruby still tries to use -ltcl -ltk as linker options for the tk extension (instead of -ltcl85 -ltk85), which causes the tk extension not to build.  This is due to a bug in the tk extconf.rb file, which should be fixed by the attached patch.


-- 
http://bugs.ruby-lang.org/