Issue #9320 has been updated by hsbt (Hiroshi SHIBATA).


>phasis68

Thank you for your report. 404 error of ruby-lang.org is caused by r44459 too.
----------------------------------------
Bug #9320: Nightly Snapshot is not found
https://bugs.ruby-lang.org/issues/9320#change-43957

Author: phasis68 (Heesob Park)
Status: Open
Priority: Normal
Assignee: 
Category: 
Target version: 
ruby -v: ruby-2.2.0-r44459
Backport: 1.9.3: UNKNOWN, 2.0.0: UNKNOWN, 2.1: UNKNOWN


If I click the Nightly Snapshot link on the http://www.ruby-lang.org/en/downloads/, It raised "404 Not Found" error.

When I try to build the latest snapshot, 

# ruby tool/make-snapshot /tmp/snapshot/ trunk
Exporting trunk@44459
Exported revision 44459.
take a breath, and go ahead
creating configure... done
creating prerequisites...
generating id.h
id.h updated
generating opt_sc.inc
generating optinsn.inc
generating optunifs.inc
generating insns.inc
generating insns_info.inc
generating vmtc.inc
generating vm.inc
generating node_name.inc
generating encdb.h
encdb.h updated
rbconfig.rb updated
generating enc.mk
/tmp/ruby-snapshot20131230-4403-fmvml0/ruby-2.2.0-r44459/lib/mkmf.rb:2401:in `dup': can't dup NilClass (TypeError)
        from /tmp/ruby-snapshot20131230-4403-fmvml0/ruby-2.2.0-r44459/lib/mkmf.rb:2401:in `init_mkmf'
        from /tmp/ruby-snapshot20131230-4403-fmvml0/ruby-2.2.0-r44459/lib/mkmf.rb:2484:in `<module:MakeMakefile>'
        from /tmp/ruby-snapshot20131230-4403-fmvml0/ruby-2.2.0-r44459/lib/mkmf.rb:47:in `<top (required)>'
        from ./enc/make_encmake.rb:8:in `load'
        from ./enc/make_encmake.rb:8:in `<main>'
make: *** [enc.mk] Error 1
prerequisites failed

This error was introduced with r44459.




-- 
http://bugs.ruby-lang.org/