Issue #9313 has been reported by marciotrindade (Marcio Trindade).

----------------------------------------
Bug #9313: Segmentation fault with active_record
https://bugs.ruby-lang.org/issues/9313

Author: marciotrindade (Marcio Trindade)
Status: Open
Priority: Normal
Assignee: 
Category: lib/rubygems
Target version: 
ruby -v: 2.1.0-p0
Backport: 2.1: UNKNOWN


Hi,

I got the same problem with 2 different macbook.

/Users/marciotrindade/.rvm/gems/ruby-2.1.0/gems/activerecord-4.0.2/lib/active_record/transactions.rb:265: [BUG] Segmentation fault at 0x00000000000018                                                                                                         |  ETA: 00:00:24
ruby 2.1.0p0 (2013-12-25 revision 44422) [x86_64-darwin13.0]

-- Crash Report log information --------------------------------------------
   See Crash Report log file under the one of following:
     * ~/Library/Logs/CrashReporter
     * /Library/Logs/CrashReporter
     * ~/Library/Logs/DiagnosticReports
     * /Library/Logs/DiagnosticReports
   for more details.

-- C level backtrace information -------------------------------------------
0   libruby.2.1.0.dylib                 0x00000001098a57ad rb_vm_bugreport + 141
1   libruby.2.1.0.dylib                 0x000000010976ecad report_bug + 285
2   libruby.2.1.0.dylib                 0x000000010976eb83 rb_bug + 179
3   libruby.2.1.0.dylib                 0x000000010982dd29 sigsegv + 153
4   libsystem_platform.dylib            0x00007fff80d9e5aa _sigtramp + 26
5   libruby.2.1.0.dylib                 0x000000010988d450 vm_exec_core + 10496
6   libsystem_c.dylib                   0x00007fff72b86400 __stack_chk_guard + 0


To see the complete backtrace please visit https://gist.github.com/marciotrindade/8155638


-- 
http://bugs.ruby-lang.org/